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QUICKFACTS
UNDERSTANDING CELL
REFERENCING TYPES
There are three basic methods and one extended method
for referencing cells used in formulas that adhere to the

3

Excel default “A1” cell reference scheme used in this book.

• Relative references in formulas move with cells as
cells are copied or moved around a worksheet. This
is the most flexible and common way to use cell

44

references, and is the Excel default, displayed as
A1 in the worksheet and Formula bar. For example,
if you sum a list of revenue items for the first

5

quarter, =SUM(B5:B8), and then copy and paste

Reference Cells
Formulas typically make use of data already entered in worksheets and need
a scheme to locate, or reference, that data. Shortcuts are used to help you recall
addresses as well as a syntax, or set of rules, to communicate to Excel how you
want cells used.

Change Cell References
To change cell referencing:

1. Select the cell that contains the formula reference you want to change.
2. In the Formula bar, select the cell address, and press F4 to switch the cell referencing,

that summary cell to the summary cells for the other

starting from a relative reference to the following in this order:

three quarters, Excel will deduce that you want the

• Absolute ($A$1)
• Mixed (relative column, absolute row) (A$1)
• Mixed (absolute column, relative row) ($A1)
• Relative (A1)

totals for the other quarters to be =SUM(C5:C8),
=SUM(D5:D8), and =SUM(E5:E8). Figure 4-1
shows how this appears on the worksheet.

6

• Absolute references do not change cell
addresses when you copy or move formulas.

–Or–

Absolute references are displayed in the

Edit the cell address by entering or removing the dollar symbol ($) in front of row
and/or column identifiers.

worksheet and Formula bar with the dollar sign
preceding the reference, for example, $A$1.

7

• Mixed references include one relative and one
absolute cell reference. Such references are
displayed in the worksheet and Formula bar with
a dollar sign preceding the absolute reference but
no dollar sign before the relative reference. For

8

example, $A1 indicates absolute column, relative
row; A$1 indicates relative column, absolute row.

• External (or 3-D) references are an extended form
of relative, absolute, and mixed cell references.

Change to R1C1 References
You can change the A1 cell referencing scheme used by Excel to an older style
that identifies both rows and columns numerically, starting in the upper-left
corner of the worksheet, rows first, and adds a leading R and C for clarification.
For example, cell B4 in R1C1 reference style is R4C2.

1. Click the File tab, click Options, and click the Formulas option.
2. Under Working With Formulas, click the R1C1 Reference
Style check box.

9

They are used when referencing cells from other
worksheets or workbooks. Such a reference might

3. Click OK when finished.

look like this in the worksheet and Formula bar:

10

[workbook name]worksheet name!A1.
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TIP
To view formulas instead of cell values (see Figure 4-1),
Formulas

. Click the button a second time to return

to a value display.

3

in the Formulas tab Formula Auditing group, click Show

You can name a cell (MonthTotal, for example) or a range to refer to physical
cell addresses, and then use the names when referencing the cell in formulas
and functions. Names are more descriptive, easier to remember, and often
quicker to enter than A1-style cell references. You can name a cell directly on the
worksheet, use a dialog box and provide amplifying information, or use column
or row names.

2

Name Cells

1
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NAME A CELL OR RANGE DIRECTLY

44

1. Select the cells you want to reference.
2. Click the Name box at the left end of the Formula bar.

5
6
7
8

…and pasting into C9, D9, E9, and F9 provides
correct cell addresses for each column total

9

Copying B9, which
sums B5 through B8…

Figure 4-1: Using relative references, Excel logically assumes cell addresses in copied formulas.
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2

TIP

3. Type a name (see the accompanying Caution for naming rules), and press ENTER.

Absolute cell references are typically used when you

(See “Use the Name Manager” for ways to modify cell names.)

want to copy the values of cells and are not interested
This cell can now be
referenced by either its…

in applying their formulas to other cells, such as in
a summary or report where the relative references

3

would be meaningless. Though you can apply absolute
…name or…

reference syntax to each cell reference, a faster way is to
right-click the destination cell. Under Paste Options, click
the Values

…its location

option. See “Copy Formulas” later in

44

the chapter for more information on copying and pasting
formulas.

NAME A CELL OR RANGE IN A DIALOG BOX

5

TIP

–Or–

If a cell or range name is longer than what can be
displayed in the Name box, increase the width of the

Right-click the selection and click Define Name.

Name box by dragging the circle in the arc forming its

In the either case, the New Name dialog box appears, shown in Figure 4-2.

right boundary to

6

1. Select the cells you want to reference.
2. In the Formulas tab Defined Names group, click Define Name.

the right.

3. Type a name for the cell or range (see the accompanying Caution for naming rules).
4. Click the Scope down arrow, and select whether the name applies to the entire
workbook or to one of its worksheets.

7

CAUTION
Cell names need to adhere to a set of rules. Names
are case-sensitive, and no spaces are allowed in a cell

8

name, although multiple words can be joined by an
underscore or period. Also, names must start with a

9

letter, underscore (_), or backslash (\).

10

Figure 4-2: You can easily name cells and add
descriptive information.
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UICKSTEPS

5. If desired, type a comment that more fully explains the meaning of the named cells.
Comments can be upwards of 1,000 characters and will appear as a tooltip when the
name is used in formulas and functions.

2

USING CELL REFERENCE
OPERATORS

1

Information has been obtained by McGraw-Hill from sources believed to be reliable. However, because of the possibility of human
or mechanical error by our sources, McGraw-Hill, or others, McGraw-Hill does not guarantee the accuracy, adequacy, or completeness of any information and is not responsible for any errors or omissions or the results obtained from the use of such information.

Cell reference operators (colons, commas, and spaces
used in an address, such as E5:E10 E16:E17,E12)

3

provide the syntax for referencing cell ranges, unions,
and intersections.
REFERENCE A RANGE
A range defines a block of cells.

upper-leftmost cell and the lowerrightmost cell (for example, B5:C8).

6. If you want to modify the cell or cells to be named, click the Refers To text box, and type

44

Type a colon (:) between the

the reference (starting with the equal [=] sign), or reselect the cells from the worksheet.

7. Click OK when finished.

REFERENCE A UNION
references.
Type a comma (,) between
separate cell references
(for example, B5,B7,C6).

An intersection is the overlapping, or common, cells in

Named cells are quickly found and selected
for you.
Click the Name box down arrow to open the
drop-down list, and click the named cell or
range you want to go to.

6

REFERENCE AN INTERSECTION

Go to a Named Cell

5

A union joins multiple cell

–Or–

Type a space (press the

In the Home tab Editing group, click Find & Select and click Go To. In the Go To dialog
box, double-click the named cell or range you want to go to.

SPACEBAR) between two

7

two ranges.

range-cell references (for
example, B5:B8 B7:C8). B7
and B8 are the common
this example).

Excel provides several related tools and a Name Manager to help you manage
and organize your named cells. To open the Name Manager:
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9

In the Formulas tab Defined Names group, click
Name Manager. The Name Manager window
opens, as shown in Figure 4-3, listing all named
cells in the workbook.

8

cells (and are summed in

Use the Name Manager

3/31/10 11:48:57 AM
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CHANGE CELL NAMES

2

1. Select the name of the cell reference whose parameters you
want to change, and click Edit.

2. In the Edit Name dialog box, type a new name, add or change

3

the comment, and/or modify the cell reference (you cannot
change the scope). Click OK when finished.

DELETE NAMED CELLS

1. Select the name of the cell reference that you want to delete (to

44

select more than one cell name to delete, hold down the CTRL
key while clicking noncontiguous names in the list; or select the
first name in a contiguous range, and hold down SHIFT while
clicking the last name in the range).

2. Click Delete and click OK to confirm the deletion.

5

SORT AND FILTER NAMED CELLS

If you have several named cells in a workbook, you can
easily view only the ones you are interested in.

6

1. To sort named cells, click a column heading to change the
Figure 4-3: The Name Manager provides a central location for organizing, creating,
and modifying named cells.

sort order from ascending (numerals first 0–9, then A–Z) to
descending (Z–A, numerals last 9–0). Click the heading a
second time to return to the original order.

–Or–

9

8

7

To see only specific categories of named cells, click Filter and click the category of
named cells you want to see. Only named cells that belong in the category you select
will appear in the list of cell names.

10

2. To return a filtered list to a complete list of named cells, click Filter and click Clear Filter.
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TIP

VIEW MORE DATA

2

To quickly open the Name Manager, press CTRL+F3 or

Access toolbar.)

•

To increase a column width, drag the right border of the column heading to the right as
far as you need.

•

To increase the width of the window, drag either the window’s right or left border to the
left or right, respectively.

TIP
Excel provides several concessions for users who are
when creating a formula, you can type a plus sign (+)
instead of the equal sign to denote a formula. Excel will
change the plus sign to an equal sign if a number follows
it, or Excel will add the equal sign to a plus sign that is
type a leading space before either the plus or the equal
sign, as the characters that follow will be interpreted as
text instead of as a formula. To enable Lotus transitioning,
click the File tab, click Options, and click the Advanced
bottom of the page, select the options you want and
whether they apply to specific sheets or the entire
workbook. Click OK when finished.

Create a Formula
You create formulas by either entering or referencing values. The character that
tells Excel to perform a calculation is the equal sign (=), and it must precede any
combination of values, cell references, and operators.

10
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Excel formulas are calculated from left to right according to an ordered hierarchy
of operators. For example, exponents precede multiplication and division,
which precede addition and subtraction. You can alter the calculation order
(and results) by using parentheses; Excel performs the calculation within the
innermost parentheses first. For example, =12+48/24 returns 14 (48 is divided by
24, resulting in 2; then 12 is added to 2). Using parentheses, =(12+48)/24 returns
2.5 (12 is added to 48, resulting in 60; then 60 is divided by 24).

7

option. Under the two Lotus Compatibility areas at the

6

followed by a cell reference. In any case, be sure not to

Formulas are mathematical equations that combine values and cell references with
operators to calculate a result. Values are actual numbers or logical values, such
as True and False, or the contents of cells that contain numbers or logical values.
Cell references point to cells whose values are to be used, for example, E5:E10,
E12, and MonthlyTot. Operators, such as + (add), > (greater than), and ^ (use an
exponent), tell Excel what type of calculation to perform or logical comparison
to apply. Prebuilt formulas, or functions, that return a value also can be used in
formulas. (Functions are described later in this chapter.)

5

transitioning to Excel from Lotus 1-2-3. For example,

44

Build Formulas

3

(Chapter 1 describes how to add tools to the Quick

The default width of the Name Manager and its columns might not readily
display longer cell names, references, or comments.

add the Name Manager icon to the Quick Access toolbar.
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